Introduction
User Interface
How to...
Order

Help > How to translate Zentimo

If you haven't found your native language among supported by the program languages, you can translate the program to your native language. We award our translators by free licenses for the translation! Please, don't forget to contact us before making the translation! Probably someone is already translating the program to your language.

Step-by-step manuals

I. Translation from the scratch. Use this manual if you do not see your languages among the supported by your program.
  1. Download the latest beta-version (or stable if there are no betas available) of the program here: http://zentimo.com/download.htm and install it. Then proceed to the program's folder - %Program Files%\Zentimo, here you'll see the folder "Languages", enter to this folder.
  2. In Languages folder select one of the language files - i.e. Russian.lng, rename it to <Your_language_name>.lng
  3. Open <Your_language_name>.lng file in editor* and translate all the strings. They have the next format: english_phrase=native_phrase. You have to delete a text after '=' sign and write translated text there.
  4. After you will have translated all the strings, restart program, and go to the program Options -> General tab, Languages section, choose your language there.
  5. Play with the program, check that all strings are translated and they are fit into their places.
  6. Send us <Your_language_name>.lng file
II. Update existing translation. If you find the translation to your language to be uncomplete or incorrect you can translate it and send to us, moreover you can become the translator to this langauge. This help to us is also very appreciated and we are happy to reward you with a license for it.
  1. Contact us before you wish to do the translation
  2. Download the latest beta-version (or stable if there are no betas available) of the program here: http://zentimo.com/download.htm and install it. Then proceed to the program's folder - %Program Files%\Zentimo, here you'll see the folder "Languages", enter to this folder.
  3. In the "Languages" subfolder find <Your_language_name>.lng file
  4. Open <Your_language_name>.lng file in editor* and translate all the untranslated strings . They have the next format: english_phrase=native_phrase. Some phrases are already translated and some are not. You need to add your translation to the left of "=" sign.
  5. After you have translated all the strings, restart program, and go to the program Options -> General tab, Languages section, choose your language there.
  6. Play with the program, check that all the strings are translated and they are fit into their places.
  7. Send us <Your_language_name>.lng file
* It's recommended to use a plain-text editor (rather than Word) such as notepad, notepad++, PSPad